// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\s?\n+\s+|\n)").unwrap();
let string = "<all-tags
with-their=\"attribute\"
even-if-there=\"are-more\"
aa=\"1\">and all the content between
the start and end tag</all-tags><meta-tag />";
let substitution = " ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}