const regex = /(\s?\n+\s+|\n)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\s?\\n+\\s+|\\n)', 'g')
const str = `<all-tags
with-their="attribute"
even-if-there="are-more"
aa="1">and all the content between
the start and end tag</all-tags><meta-tag />`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);