import Foundation
let pattern = #"(\s?\n+\s+|\n)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<all-tags
with-their="attribute"
even-if-there="are-more"
aa="1">and all the content between
the start and end tag</all-tags><meta-tag />
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)