# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^([b-df-hj-np-tv-xz]+)([a-z]+)$/$2-$1/gmi;t' <<< "bbber
bert
avokado"