package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^([b-df-hj-np-tv-xz]+)([a-z]+)$`)
var str = `bbber
bert
avokado`
var substitution = "$2-$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}