import Foundation
let pattern = #"^([b-df-hj-np-tv-xz]+)([a-z]+)$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
bbber
bert
avokado
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2-$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)