#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(\/\*[\S\s]*?\*\/)"
Local $sString = "This is/ some code /* these are some comments" & @CRLF & _
"=412414515/ * somechars / ][;';'] */*/" & @CRLF & _
"Some more code " & @CRLF & _
"/* and some more unreadable comments a[dpas[;[];135///]] " & @CRLF & _
"d0gewt0qkgekg;l''\////" & @CRLF & _
"*/ god i hate regex /* asda*asd" & @CRLF & _
"\asd*sd */"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")