import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\/\\*[\\S\\s]*?\\*\\/)";
final String string = "This is/ some code /* these are some comments\n"
+ "=412414515/ * somechars / ][;';'] */*/\n"
+ "Some more code \n"
+ "/* and some more unreadable comments a[dpas[;[];135///]] \n"
+ "d0gewt0qkgekg;l''\\////\n"
+ "*/ god i hate regex /* asda*asd\n"
+ "\\asd*sd */";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}