package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\/\*[\S\s]*?\*\/)`)
var str = `This is/ some code /* these are some comments
=412414515/ * somechars / ][;';'] */*/
Some more code
/* and some more unreadable comments a[dpas[;[];135///]]
d0gewt0qkgekg;l''\////
*/ god i hate regex /* asda*asd
\asd*sd */`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}