import re
regex = re.compile(r"(\/\*[\S\s]*?\*\/)")
test_str = ("This is/ some code /* these are some comments\n"
"=412414515/ * somechars / ][;';'] */*/\n"
"Some more code \n"
"/* and some more unreadable comments a[dpas[;[];135///]] \n"
"d0gewt0qkgekg;l''\\////\n"
"*/ god i hate regex /* asda*asd\n"
"\\asd*sd */")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")