$re = '/(\/\*[\S\s]*?\*\/)/';
$str = 'This is/ some code /* these are some comments
=412414515/ * somechars / ][;\';\'] */*/
Some more code
/* and some more unreadable comments a[dpas[;[];135///]]
d0gewt0qkgekg;l\'\'\\////
*/ god i hate regex /* asda*asd
\\asd*sd */';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);