using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\/\*[\S\s]*?\*\/)";
string input = @"This is/ some code /* these are some comments
=412414515/ * somechars / ][;';'] */*/
Some more code
/* and some more unreadable comments a[dpas[;[];135///]]
d0gewt0qkgekg;l''\////
*/ god i hate regex /* asda*asd
\asd*sd */";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}