#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([a-z]|\b-\b){1,30}$"
Local $sString = "ababab-asd" & @CRLF & _
"aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa" & @CRLF & _
"sssssssssssssssss-s-s-s-sss" & @CRLF & _
"sdsds-sd-sd-s-d-sd---sd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")