using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([a-z]|\b-\b){1,30}$";
string input = @"ababab-asd
aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
sssssssssssssssss-s-s-s-sss
sdsds-sd-sd-s-d-sd---sd";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}