package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([a-z]|\b-\b){1,30}$`)
var str = `ababab-asd
aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa
sssssssssssssssss-s-s-s-sss
sdsds-sd-sd-s-d-sd---sd`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}