import re
regex = re.compile(r"^([a-z]|\b-\b){1,30}$", flags=re.MULTILINE)
test_str = ("ababab-asd\n"
"aaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaaa\n"
"sssssssssssssssss-s-s-s-sss\n"
"sdsds-sd-sd-s-d-sd---sd")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")