using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"a href=""([^""]+)"".+img src=""([^""]+)";
string input = @"<p style=""text-align: center;""><a href=""/upload/obzor-PG32UQX/"" class=""fancybox""><img src=""/upload/obzor-PG32UQX/01_tab1.png""></a></p>
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}