// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)a href="([^"]+)".+img src="([^"]+)"#).unwrap();
let string = "<p style=\"text-align: center;\"><a href=\"/upload/obzor-PG32UQX/\" class=\"fancybox\"><img src=\"/upload/obzor-PG32UQX/01_tab1.png\"></a></p>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}