re = /a href="([^"]+)".+img src="([^"]+)/m
str = '<p style="text-align: center;"><a href="/upload/obzor-PG32UQX/" class="fancybox"><img src="/upload/obzor-PG32UQX/01_tab1.png"></a></p>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end