package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)a href="([^"]+)".+img src="([^"]+)`)
var str = `<p style="text-align: center;"><a href="/upload/obzor-PG32UQX/" class="fancybox"><img src="/upload/obzor-PG32UQX/01_tab1.png"></a></p>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}