$re = '/a href="([^"]+)".+img src="([^"]+)/m';
$str = '<p style="text-align: center;"><a href="/upload/obzor-PG32UQX/" class="fancybox"><img src="/upload/obzor-PG32UQX/01_tab1.png"></a></p>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);