#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(3[6-9]|4[0-3]|3[6-9].[0-9]{1,2}|4[0-2].[0-9]{1,2})$"
Local $sString = "32" & @CRLF & _
"33" & @CRLF & _
"34" & @CRLF & _
"35" & @CRLF & _
"35.9" & @CRLF & _
"36" & @CRLF & _
"36.2" & @CRLF & _
"36.21" & @CRLF & _
"36.67" & @CRLF & _
"36.42" & @CRLF & _
"36.8" & @CRLF & _
"37" & @CRLF & _
"38" & @CRLF & _
"39" & @CRLF & _
"39.05" & @CRLF & _
"39.34" & @CRLF & _
"40" & @CRLF & _
"40.01" & @CRLF & _
"41" & @CRLF & _
"41.3" & @CRLF & _
"41.42" & @CRLF & _
"41.67" & @CRLF & _
"42" & @CRLF & _
"42.1" & @CRLF & _
"42.25" & @CRLF & _
"42.8" & @CRLF & _
"43" & @CRLF & _
"43.6" & @CRLF & _
"44" & @CRLF & _
"45" & @CRLF & _
"46" & @CRLF & _
"47"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")