# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(3[6-9]|4[0-3]|3[6-9].[0-9]{1,2}|4[0-2].[0-9]{1,2})$"
test_str = ("32\n"
"33\n"
"34\n"
"35\n"
"35.9\n"
"36\n"
"36.2\n"
"36.21\n"
"36.67\n"
"36.42\n"
"36.8\n"
"37\n"
"38\n"
"39\n"
"39.05\n"
"39.34\n"
"40\n"
"40.01\n"
"41\n"
"41.3\n"
"41.42\n"
"41.67\n"
"42\n"
"42.1\n"
"42.25\n"
"42.8\n"
"43\n"
"43.6\n"
"44\n"
"45\n"
"46\n"
"47")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.