using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(3[6-9]|4[0-3]|3[6-9].[0-9]{1,2}|4[0-2].[0-9]{1,2})$";
string input = @"32
33
34
35
35.9
36
36.2
36.21
36.67
36.42
36.8
37
38
39
39.05
39.34
40
40.01
41
41.3
41.42
41.67
42
42.1
42.25
42.8
43
43.6
44
45
46
47";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}