import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(3[6-9]|4[0-3]|3[6-9].[0-9]{1,2}|4[0-2].[0-9]{1,2})$";
final String string = "32\n"
+ "33\n"
+ "34\n"
+ "35\n"
+ "35.9\n"
+ "36\n"
+ "36.2\n"
+ "36.21\n"
+ "36.67\n"
+ "36.42\n"
+ "36.8\n"
+ "37\n"
+ "38\n"
+ "39\n"
+ "39.05\n"
+ "39.34\n"
+ "40\n"
+ "40.01\n"
+ "41\n"
+ "41.3\n"
+ "41.42\n"
+ "41.67\n"
+ "42\n"
+ "42.1\n"
+ "42.25\n"
+ "42.8\n"
+ "43\n"
+ "43.6\n"
+ "44\n"
+ "45\n"
+ "46\n"
+ "47";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}