package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(3[6-9]|4[0-3]|3[6-9].[0-9]{1,2}|4[0-2].[0-9]{1,2})$`)
var str = `32
33
34
35
35.9
36
36.2
36.21
36.67
36.42
36.8
37
38
39
39.05
39.34
40
40.01
41
41.3
41.42
41.67
42
42.1
42.25
42.8
43
43.6
44
45
46
47`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}