# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^i]*i)i*([^\r\n]*)/\1\2/gm;t' <<< "123iiii
123iiiiabc"