use strict;
my $str = '123iiii
123iiiiabc';
my $regex = qr/([^i]*i)i*([^\r\n]*)/mp;
my $subst = '\\1\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";