const regex = /([^i]*i)i*([^\r\n]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^i]*i)i*([^\\r\\n]*)', 'gm')
const str = `123iiii
123iiiiabc`;
const subst = `\1\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);