package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^i]*i)i*([^\r\n]*)`)
var str = `123iiii
123iiiiabc`
var substitution = "\1\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}