$re = '/([^i]*i)i*([^\r\n]*)/m';
$str = '123iiii
123iiiiabc';
$subst = "\1\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;