using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^i]*i)i*([^\r\n]*)";
string substitution = @"\1\2";
string input = @"123iiii
123iiiiabc";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}