#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Foo\K(?:(?!^Foo)[\S\s])+(?=^Yes)"
Local $sString = "Foo $var1 <br/>" & @CRLF & _
"......... <br/>" & @CRLF & _
"......... <br/><br/>" & @CRLF & _
"Foo $var2 <br/>" & @CRLF & _
"..........<br/>" & @CRLF & _
"..........<br/>" & @CRLF & _
"..........<br/>" & @CRLF & _
"Yes" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")