re = /(?m)^Foo\K(?:(?!^Foo)[\S\s])+(?=^Yes)/
str = 'Foo $var1 <br/>
......... <br/>
......... <br/><br/>
Foo $var2 <br/>
..........<br/>
..........<br/>
..........<br/>
Yes
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end