import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)^Foo\\K(?:(?!^Foo)[\\S\\s])+(?=^Yes)";
final String string = "Foo $var1 <br/>\n"
+ "......... <br/>\n"
+ "......... <br/><br/>\n"
+ "Foo $var2 <br/>\n"
+ "..........<br/>\n"
+ "..........<br/>\n"
+ "..........<br/>\n"
+ "Yes\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}