import Foundation
let pattern = #"(?m)^Foo\K(?:(?!^Foo)[\S\s])+(?=^Yes)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Foo $var1 <br/>
......... <br/>
......... <br/><br/>
Foo $var2 <br/>
..........<br/>
..........<br/>
..........<br/>
Yes
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)