$re = '/(?m)^Foo\K(?:(?!^Foo)[\S\s])+(?=^Yes)/';
$str = 'Foo $var1 <br/>
......... <br/>
......... <br/><br/>
Foo $var2 <br/>
..........<br/>
..........<br/>
..........<br/>
Yes
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);