using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)^Foo\K(?:(?!^Foo)[\S\s])+(?=^Yes)";
string input = @"Foo $var1 <br/>
......... <br/>
......... <br/><br/>
Foo $var2 <br/>
..........<br/>
..........<br/>
..........<br/>
Yes
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}