#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)(<!--.*?-->)| "
Local $sString = "<div>" & @CRLF & _
" <p>Sample text!</p>" & @CRLF & _
" <!--" & @CRLF & _
" <img src="test.jpg" alt="This is an image!" width="500" height="600">" & @CRLF & _
" -->" & @CRLF & _
"</div>" & @CRLF & _
"<div>" & @CRLF & _
" <p>Sample text!</p>" & @CRLF & _
" <!--" & @CRLF & _
" <img src="test.jpg" alt="This is an image!" width="500" height="600">" & @CRLF & _
" -->" & @CRLF & _
"</div>" & @CRLF & _
"<div>" & @CRLF & _
" <p>Sample text!</p>" & @CRLF & _
" <!--" & @CRLF & _
" <img src="test.jpg" alt="This is an image!" width="500" height="600">" & @CRLF & _
" -->" & @CRLF & _
"</div>"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)