// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s)(<!--.*?-->)| ").unwrap();
let string = "<div>
<p>Sample text!</p>
<!--
<img src=\"test.jpg\" alt=\"This is an image!\" width=\"500\" height=\"600\">
-->
</div>
<div>
<p>Sample text!</p>
<!--
<img src=\"test.jpg\" alt=\"This is an image!\" width=\"500\" height=\"600\">
-->
</div>
<div>
<p>Sample text!</p>
<!--
<img src=\"test.jpg\" alt=\"This is an image!\" width=\"500\" height=\"600\">
-->
</div>";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}