import Foundation
let pattern = #"(<!--.*?-->)| "#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
<div>
<p>Sample text!</p>
<!--
<img src="test.jpg" alt="This is an image!" width="500" height="600">
-->
</div>
<div>
<p>Sample text!</p>
<!--
<img src="test.jpg" alt="This is an image!" width="500" height="600">
-->
</div>
<div>
<p>Sample text!</p>
<!--
<img src="test.jpg" alt="This is an image!" width="500" height="600">
-->
</div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)