using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<!--.*?-->)| ";
string substitution = @"$1";
string input = @"<div>
<p>Sample text!</p>
<!--
<img src=""test.jpg"" alt=""This is an image!"" width=""500"" height=""600"">
-->
</div>
<div>
<p>Sample text!</p>
<!--
<img src=""test.jpg"" alt=""This is an image!"" width=""500"" height=""600"">
-->
</div>
<div>
<p>Sample text!</p>
<!--
<img src=""test.jpg"" alt=""This is an image!"" width=""500"" height=""600"">
-->
</div>";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}