re = /(<!--.*?-->)| /
str = '<div>
<p>Sample text!</p>
<!--
<img src="test.jpg" alt="This is an image!" width="500" height="600">
-->
</div>
<div>
<p>Sample text!</p>
<!--
<img src="test.jpg" alt="This is an image!" width="500" height="600">
-->
</div>
<div>
<p>Sample text!</p>
<!--
<img src="test.jpg" alt="This is an image!" width="500" height="600">
-->
</div>'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result