$re = '/(<!--.*?-->)| /s';
$str = '<div>
<p>Sample text!</p>
<!--
<img src="test.jpg" alt="This is an image!" width="500" height="600">
-->
</div>
<div>
<p>Sample text!</p>
<!--
<img src="test.jpg" alt="This is an image!" width="500" height="600">
-->
</div>
<div>
<p>Sample text!</p>
<!--
<img src="test.jpg" alt="This is an image!" width="500" height="600">
-->
</div>';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;