import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([a-zA-Z0-9-]+):([a-zA-Z0-9-]+)";
final String string = "{ \n"
+ "time: { \n"
+ " from:now-60d,\n"
+ " mode:quick,\n"
+ " to:now } \n"
+ "}";
final String subst = "\"$1\":\"$2\"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}