const regex = /([a-zA-Z0-9-]+):([a-zA-Z0-9-]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-zA-Z0-9-]+):([a-zA-Z0-9-]+)', 'g')
const str = `{
time: {
from:now-60d,
mode:quick,
to:now }
}`;
const subst = `"$1":"$2"`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);