import Foundation
let pattern = #"([a-zA-Z0-9-]+):([a-zA-Z0-9-]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
{
time: {
from:now-60d,
mode:quick,
to:now }
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""$1":"$2""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)