re = /([a-zA-Z0-9-]+):([a-zA-Z0-9-]+)/
str = '{
time: {
from:now-60d,
mode:quick,
to:now }
}'
subst = '"$1":"$2"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result