use strict;
my $str = '{
time: {
from:now-60d,
mode:quick,
to:now }
}';
my $regex = qr/([a-zA-Z0-9-]+):([a-zA-Z0-9-]+)/p;
my $subst = '"$1":"$2"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";