using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[A-CEGHJ-PR-TW-Z]{2}[0-9]{6}[A-DFM]{1}$";
string input = @"QQ123456C
AA123456C
KM673437D
AQ123456C
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}